Commodore Plus 4 Repair 2



Not another plus4? This plus4 needed, well the usual stuff.. a new chip, new capacitors, and a nice heat spreader..

P4r2yk.jpg

This slightly yellowed plus4 was sent to me with a blank screen fault. Ted? PLA? CPU? Or just broken.. You decide!

P4r2pcb1.jpg

Nice clean PCB, no signs of damage. At the point, I just turn them on (using my own tested PSU, not Mr Over voltage 2013), and see what gets hot. Or even lack of hotness!

P4r2doneanddone.jpg

So this one didn't need much more than a finger to tell me what was wrong.. Didn't even turn on my scope! Anywho, I converted a good C64 PSU for use on the Plus4, stuck on all of the usual heatsinks and new caps.. And Bobs your aunt!


P4rPSU.jpg

Hmm.. Extended power cable? First job is always to test the old PSU. Most Commodore PSU's are potted (epoxy plastic type stuff), this makes them un-repairable, and unreliable. As the epoxy works as an efficient PSU cooking compound! So I wan't too surprised to find this thing was outputting it's 5v DC at 5.9, but better than that, leave it on for a bit, and you got 7.4volts. Me thinks this is what caused the blank screen.

P4r2cpu.jpg

The prize for extra hotness went to the CPU. It starts frying eggs the moment you turn on. And that was it, 8ish volts to your CPU kills the CPU. Funny that. If you are running any Commodore on an old supply, please check the 5v line. If it's over 5.4volt's, junk it. When it's under load, the voltage will rise.. Just put it in the bin! I keep seeing people in the lemon64 forums suggest all kinds of funny ways to replace the PSU. Like using two wall warts!. There are plenty of reasons not to do this. Just find an old Vic/64 supply and convert the cable.


Fix it, before it becomes landfill.